mac下升级xcode导致git不可用的解决办法

打开iterm,更新代码,报如下错误:

➜  spring-framework git pull

Agreeing to the Xcode/iOS license requires admin privileges, please run “sudo xcodebuild -license” and then retry this command.

IDEA也会有如下错误提示

file

根据错误提示,回想最近升级过xcode,打开一看,需要输入密码,同意相关协议,安装新组件。当xcode组件安装完成git也就正常了。

file