mac 环境下配置eclipse使用的JDK版本

    在WINDOWS环境下,可以指定ECLIPSE启动使用的JDK版本,在MAC环境下配置方式也类似:同样可以在eclipse.ini文件中以-vm的方式指定。如果你刚使用MAC不久,遇到高版本eclipse不支持低版本JDK的总是,可以安装高版本的JDK,然后在eclipse.ini文件中指定这个版本。具体做法如下:

   1,执行 ls -ltr /Library/Java/JavaVirtualMachines 命令查看本地所有的JDK版本及路径信息。

    2,在eclisep.ini文件中添加以下配置内容指定JDK版本:

-vm
/Library/Java/JavaVirtualMachines/${JDK.VERSION}/Contents/Home/bin/java

    上述配置文件中的第二行根据机器上的安装路径信息实际配置。

    完成上述步骤后,就可以启动你的ECLIPSE啦。