升级UEditor语法高亮插件SyntaxHighlighter

    ueditor使用SyntaxHighlighter插件实现语法高亮功能,但默认集成的SyntaxHighlighter存在显示问题,详见 http://www.coolskill.net/article/code-snippet-syntaxhighlighter-by-ueditor.htm    这篇文章介绍,后续使用中,发现代码不能复制粘贴,对于需要参与文章中引用的代码的朋友,很不友好,所以趁着周末解决一下这个问题。

    记得开源中国的代码高亮插件也是这个,但那个是支持复制代码片断的,猜测是版本过低,研究发现的确是ueditor默认集成的SyntaxHighlighter版本很老(v.1.5.1),需要升能一下插件版本应当就可以解决这个问题。

    升级步骤很简单,去官网下载新版本的代码包,升级相应的JS及CSS文件就可以了。最省事的方式就是将对应的文件合并成一个文件后将内容复制到原有的文件名中,这样就可以快速完成插件升级。升级完成后,双击代码片断就可以复制剪切代码内容啦。

    下载地址: http://alexgorbatchev.com/SyntaxHighlighter/ 。